IPv6

From WanWiki

Jump to: navigation, search

Contents

Configuation

Generic

A pipe with 1 mbit/s and a public IPv6 tunnel server for people, that want to experiment with IPv6 has been sponsored by Marlow.

People that are interested, get one /64 assigned, which is more than plenty adresses and YES, this is fully routed, public IPv6 Production IP space.

The tunnel-server is at 10.15.15.30 and tunnels are configured as /64 segments.

A few sites worth to visit to learn more about IPv6 are:


If you don't know, what IPv6 is, and why you should implement it, then check this out: RIPE 55: The Day The Routers Died ...

DNS

Reverse DNS etc. can be configured on request. The Wan DNS interface is currently being updated to support this.

Debian

Here is a sample configuration for Debian:

add this to /etc/network/interfaces

 auto ipv6tun
 iface ipv6tun inet6 v4tunnel
       address  2a02:0278:1000::2
       netmask  64
       endpoint 10.15.15.30
       ttl      64
       up       ip link set mtu 1480 dev ipv6tun
       up       ip route add 2000::/3 via 2a02:0278:1000::1 dev ipv6tun

Make sure to install the iproute package and to load the ipv6 module, before adding this. Loading the ipv6 module can be archieved by adding it to /etc/modules.

Mikrotik RouterOS

General notes

RouterOS supports IPv6 from 3.x. Please make sure to use at least ROS 3.0rc13.
For dynamic routing RIPng is available and works quite well.

Tunnel Setup

Here is a sample of data, needed to set up a IPv6 tunnel:

Server IPv4 address: 10.15.15.30
Server IPv6 address: 2a02:0278:1000::1/64
Client IPv4 address: 10.15.172.2
Client IPv6 address: 2a02:0278:1000::2/64

Setup the 6to4 interface

 /interface 6to4 add mtu=1480 name=ipng-tunnel local-address=10.15.172.2

Add your client IPv6 address to the new interface

 /ipv6 address add address=2a02:0278:1000::2/64 interface=ipng-tunnel

Add a default IPv6 route via your tunnel

/ipv6 route add dst-address=2000::/3 gateway=::10.15.15.30

As of ROS 3.8 the syntax for adding the default IPv6 route is:

/ipv6 route add dst-address=<destination> gateway=::<ipv4-tunnelend>,<interface>

Sample:

 /ipv6 route add dst-address=2000::/3 gateway=::10.15.15.30,ipng-tunnel

The reason is, that with multiple tunnels on multiple interfaces, RouterOS would before 3.8 have assigned the routes to random 6in4 tunnel interfaces. When upgrading from pre-3.8 to 3.8 and beyond, the static routes have to be re-created from scratch.

You can now add your assigned IPv6 addresses as required.

SixXS

Another way to get IPv6 connectivity up and running is to sign up for a SixXS account, install AICCU and request a tunnel to the Airwire PoP.
The Airwire PoP is reachable via the Wan BGP gateway, regardless if you have Internet from Airwire or not.

If you want to use this via the Wan, make sure you have a route to heimdall.airwire.ie/91.189.70.130, that goes via the Wan.

You will need to apply for an AYIYA tunnel, as we have to NAT WAN traffic to the SixXS PoP.

Ranges

These ranges are natively routed and belong to airwire's IPv6 pool

  • 2a02:0278:1000::/48 - Tunnel space
    • 2a02:0278:1000::/64 - Tunnel to Carraroe (10.15.172.2)
    • 2a02:0278:1000:1:/64 --> unused
    • 2a02:0278:1000:2:/64 --> unused
    • 2a02:0278:1000:3:/64 --> unused
    • 2a02:0278:1000:4:/64 --> unused
    • 2a02:0278:1000:5:/64 --> unused
    • 2a02:0278:1000:6:/64 --> unused
    • 2a02:0278:1000:7:/64 --> unused
    • 2a02:0278:1000:8:/64 --> unused
    • 2a02:0278:1000:9:/64 --> unused
    • 2a02:0278:1000:a:/64 --> unused
    • 2a02:0278:1000:b:/64 --> unused
    • 2a02:0278:1000:c:/64 --> unused
    • 2a02:0278:1000:d:/64 --> unused
    • 2a02:0278:1000:e:/64 --> unused
    • 2a02:0278:1000:f:/64 --> unused
    • 2a02:0278:1000:10:/64 --> unused


  • 2a02:0278:1100::/40 - User space
    • 2a02:0278:1100::/48 - Mick
      • 2a02:0278:1100::/64 - Mick - Carraroe Lan
    • 2a02:0278:1101::/48 --> unused
    • 2a02:0278:1102::/48 --> unused
    • 2a02:0278:1103::/48 --> unused
    • 2a02:0278:1104::/48 --> unused
    • 2a02:0278:1105::/48 --> unused
    • 2a02:0278:1106::/48 --> unused
    • 2a02:0278:1107::/48 --> unused
    • 2a02:0278:1108::/48 --> unused
    • 2a02:0278:1109::/48 --> unused
    • 2a02:0278:110a::/48 --> unused
    • 2a02:0278:110b::/48 --> unused
    • 2a02:0278:110c::/48 --> unused
    • 2a02:0278:110d::/48 --> unused
    • 2a02:0278:110e::/48 --> unused
    • 2a02:0278:110f::/48 --> unused
    • 2a02:0278:1110::/48 --> unused